<!DOCTYPE html>
<html dir='ltr' lang='en'>
<head>
<meta content='width=device-width, initial-scale=1' name='viewport'/>
<title>DAL &#8216;ADMIN&#8217; SUCKS K7.6 MILLION OF PRICE SUPPORT FUNDS</title>
<meta content='text/html; charset=UTF-8' http-equiv='Content-Type'/>
<!-- Chrome, Firefox OS and Opera -->
<meta content='#f9f9f9' name='theme-color'/>
<!-- Windows Phone -->
<meta content='#f9f9f9' name='msapplication-navbutton-color'/>
<meta content='blogger' name='generator'/>
<link href='https://www.pngblogs.com/favicon.ico' rel='icon' type='image/x-icon'/>
<link href='https://www.pngblogs.com/2022/12/dal-admin-sucks-k76-million-of-price.html' rel='canonical'/>
<link rel="alternate" type="application/atom+xml" title="PNGBLOGS - Atom" href="https://www.pngblogs.com/feeds/posts/default" />
<link rel="alternate" type="application/rss+xml" title="PNGBLOGS - RSS" href="https://www.pngblogs.com/feeds/posts/default?alt=rss" />
<link rel="service.post" type="application/atom+xml" title="PNGBLOGS - Atom" href="https://www.blogger.com/feeds/6500433815145563157/posts/default" />

<link rel="alternate" type="application/atom+xml" title="PNGBLOGS - Atom" href="https://www.pngblogs.com/feeds/3868800323131418005/comments/default" />
<!--Can't find substitution for tag [blog.ieCssRetrofitLinks]-->
<link href='https://blogger.googleusercontent.com/img/b/R29vZ2xl/AVvXsEihf6CfQxhQgwTQ-uTRF78Y547D5q5NhqEwhGIJJjiw1gd7rZHmxsX33HBnBbEgNjHbRk9KRo2puwLCgTawfqLEr3aq4WVvC1rt6e1YMNv-Lv47Yn6VH_pFJofxxc21LGHk0K57xXsMth0hHZ8XnbsML5wobpBdAT3bZ4GplmbOqc2vuBf_SK3lSCtP/w640-h426/DAL.webp' rel='image_src'/>
<meta content='https://www.pngblogs.com/2022/12/dal-admin-sucks-k76-million-of-price.html' property='og:url'/>
<meta content='DAL ‘ADMIN’ SUCKS K7.6 MILLION OF PRICE SUPPORT FUNDS' property='og:title'/>
<meta content='PNG&#39;S PREMIER INDEPENDENT ANTI-CORRUPTION BLOG since 2009.' property='og:description'/>
<meta content='https://blogger.googleusercontent.com/img/b/R29vZ2xl/AVvXsEihf6CfQxhQgwTQ-uTRF78Y547D5q5NhqEwhGIJJjiw1gd7rZHmxsX33HBnBbEgNjHbRk9KRo2puwLCgTawfqLEr3aq4WVvC1rt6e1YMNv-Lv47Yn6VH_pFJofxxc21LGHk0K57xXsMth0hHZ8XnbsML5wobpBdAT3bZ4GplmbOqc2vuBf_SK3lSCtP/w1200-h630-p-k-no-nu/DAL.webp' property='og:image'/>
<style type='text/css'>@font-face{font-family:'Roboto';font-style:normal;font-weight:400;src:url(//fonts.gstatic.com/s/roboto/v30/KFOmCnqEu92Fr1Mu72xKOzY.woff2)format('woff2');unicode-range:U+0460-052F,U+1C80-1C88,U+20B4,U+2DE0-2DFF,U+A640-A69F,U+FE2E-FE2F;}@font-face{font-family:'Roboto';font-style:normal;font-weight:400;src:url(//fonts.gstatic.com/s/roboto/v30/KFOmCnqEu92Fr1Mu5mxKOzY.woff2)format('woff2');unicode-range:U+0301,U+0400-045F,U+0490-0491,U+04B0-04B1,U+2116;}@font-face{font-family:'Roboto';font-style:normal;font-weight:400;src:url(//fonts.gstatic.com/s/roboto/v30/KFOmCnqEu92Fr1Mu7mxKOzY.woff2)format('woff2');unicode-range:U+1F00-1FFF;}@font-face{font-family:'Roboto';font-style:normal;font-weight:400;src:url(//fonts.gstatic.com/s/roboto/v30/KFOmCnqEu92Fr1Mu4WxKOzY.woff2)format('woff2');unicode-range:U+0370-03FF;}@font-face{font-family:'Roboto';font-style:normal;font-weight:400;src:url(//fonts.gstatic.com/s/roboto/v30/KFOmCnqEu92Fr1Mu7WxKOzY.woff2)format('woff2');unicode-range:U+0102-0103,U+0110-0111,U+0128-0129,U+0168-0169,U+01A0-01A1,U+01AF-01B0,U+1EA0-1EF9,U+20AB;}@font-face{font-family:'Roboto';font-style:normal;font-weight:400;src:url(//fonts.gstatic.com/s/roboto/v30/KFOmCnqEu92Fr1Mu7GxKOzY.woff2)format('woff2');unicode-range:U+0100-024F,U+0259,U+1E00-1EFF,U+2020,U+20A0-20AB,U+20AD-20CF,U+2113,U+2C60-2C7F,U+A720-A7FF;}@font-face{font-family:'Roboto';font-style:normal;font-weight:400;src:url(//fonts.gstatic.com/s/roboto/v30/KFOmCnqEu92Fr1Mu4mxK.woff2)format('woff2');unicode-range:U+0000-00FF,U+0131,U+0152-0153,U+02BB-02BC,U+02C6,U+02DA,U+02DC,U+2000-206F,U+2074,U+20AC,U+2122,U+2191,U+2193,U+2212,U+2215,U+FEFF,U+FFFD;}</style>
<style id='page-skin-1' type='text/css'>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</style>
<style id='template-skin-1' type='text/css'><!--
body#layout .hidden,
body#layout .invisible {
display: inherit;
}
body#layout .navigation {
display: none;
}
body#layout .page,
body#layout .sidebar_top,
body#layout .sidebar_bottom {
display: inline-block;
left: inherit;
position: relative;
vertical-align: top;
}
body#layout .page {
float: right;
margin-left: 20px;
width: 55%;
}
body#layout .sidebar-container {
float: right;
width: 40%;
}
body#layout .hamburger-menu {
display: none;
}
--></style>
<script type='text/javascript'>
        (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
        (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
        m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
        })(window,document,'script','https://www.google-analytics.com/analytics.js','ga');
        ga('create', 'UA-17557928-1', 'auto', 'blogger');
        ga('blogger.send', 'pageview');
      </script>
<script async='async' src='https://www.gstatic.com/external_hosted/clipboardjs/clipboard.min.js'></script>
<link href='https://www.blogger.com/dyn-css/authorization.css?targetBlogID=6500433815145563157&amp;zx=b25522c7-eb3e-4f6c-af80-89647c25f4d8' media='none' onload='if(media!=&#39;all&#39;)media=&#39;all&#39;' rel='stylesheet'/><noscript><link href='https://www.blogger.com/dyn-css/authorization.css?targetBlogID=6500433815145563157&amp;zx=b25522c7-eb3e-4f6c-af80-89647c25f4d8' rel='stylesheet'/></noscript>
<meta name='google-adsense-platform-account' content='ca-host-pub-1556223355139109'/>
<meta name='google-adsense-platform-domain' content='blogspot.com'/>

</head>
<body class='item-view variant-strm_light'>
<a class='skip-navigation' href='#main' tabindex='0'>
Skip to main content
</a>
<div class='page'>
<div class='bg-photo-overlay'></div>
<div class='bg-photo-container'>
<div class='bg-photo'></div>
</div>
<div class='page_body'>
<div class='centered'>
<div class='centered-top-placeholder'></div>
<header class='centered-top-container' role='banner'>
<div class='centered-top'>
<a class='return_link' href='https://www.pngblogs.com/'>
<button class='svg-icon-24-button back-button rtl-reversible-icon flat-icon-button ripple'>
<svg class='svg-icon-24'>
<use xlink:href='/responsive/sprite_v1_6.css.svg#ic_arrow_back_black_24dp' xmlns:xlink='http://www.w3.org/1999/xlink'></use>
</svg>
</button>
</a>
<div class='search'>
<button aria-label='Search' class='search-expand touch-icon-button'>
<div class='flat-icon-button ripple'>
<svg class='svg-icon-24 search-expand-icon'>
<use xlink:href='/responsive/sprite_v1_6.css.svg#ic_search_black_24dp' xmlns:xlink='http://www.w3.org/1999/xlink'></use>
</svg>
</div>
</button>
<div class='section' id='search_top' name='Search (Top)'><div class='widget BlogSearch' data-version='2' id='BlogSearch1'>
<h3 class='title'>
Search This Blog
</h3>
<div class='widget-content' role='search'>
<form action='https://www.pngblogs.com/search' target='_top'>
<div class='search-input'>
<input aria-label='Search this blog' autocomplete='off' name='q' placeholder='Search this blog' value=''/>
</div>
<input class='search-action flat-button' type='submit' value='Search'/>
</form>
</div>
</div></div>
</div>
<div class='clearboth'></div>
<div class='blog-name container'>
<div class='container section' id='header' name='Header'><div class='widget Header' data-version='2' id='Header1'>
<div class='header-widget'>
<div>
<h1>
<a href='https://www.pngblogs.com/'>
PNGBLOGS
</a>
</h1>
</div>
<p>
Tips and Contact: PNGBLOGS@GMAIL.COM
</p>
</div>
</div></div>
<nav role='navigation'>
<div class='clearboth section' id='page_list_top' name='Page List (Top)'>
</div>
</nav>
</div>
</div>
</header>
<div>
<div class='vertical-ad-container no-items section' id='ads' name='Ads'>
</div>
<main class='centered-bottom' id='main' role='main' tabindex='-1'>
<div class='main section' id='page_body' name='Page Body'>
<div class='widget Blog' data-version='2' id='Blog1'>
<div class='blog-posts hfeed container'>
<article class='post-outer-container'>
<div class='post-outer'>
<div class='post'>
<script type='application/ld+json'>{
  "@context": "http://schema.org",
  "@type": "BlogPosting",
  "mainEntityOfPage": {
    "@type": "WebPage",
    "@id": "https://www.pngblogs.com/2022/12/dal-admin-sucks-k76-million-of-price.html"
  },
  "headline": "DAL &#8216;ADMIN&#8217; SUCKS K7.6 MILLION OF PRICE SUPPORT FUNDS","description": "by  CYRIL GARE&#160; Port Moresby,&#160; Only 250,000 public servants (plus or minus) out of 8 million Papua New Guineans eat up 30 percent of our nat...","datePublished": "2022-12-01T14:01:00+10:00",
  "dateModified": "2022-12-01T14:01:54+10:00","image": {
    "@type": "ImageObject","url": "https://blogger.googleusercontent.com/img/b/R29vZ2xl/AVvXsEihf6CfQxhQgwTQ-uTRF78Y547D5q5NhqEwhGIJJjiw1gd7rZHmxsX33HBnBbEgNjHbRk9KRo2puwLCgTawfqLEr3aq4WVvC1rt6e1YMNv-Lv47Yn6VH_pFJofxxc21LGHk0K57xXsMth0hHZ8XnbsML5wobpBdAT3bZ4GplmbOqc2vuBf_SK3lSCtP/w1200-h630-p-k-no-nu/DAL.webp",
    "height": 630,
    "width": 1200},"publisher": {
    "@type": "Organization",
    "name": "Blogger",
    "logo": {
      "@type": "ImageObject",
      "url": "https://blogger.googleusercontent.com/img/b/U2hvZWJveA/AVvXsEgfMvYAhAbdHksiBA24JKmb2Tav6K0GviwztID3Cq4VpV96HaJfy0viIu8z1SSw_G9n5FQHZWSRao61M3e58ImahqBtr7LiOUS6m_w59IvDYwjmMcbq3fKW4JSbacqkbxTo8B90dWp0Cese92xfLMPe_tg11g/h60/",
      "width": 206,
      "height": 60
    }
  },"author": {
    "@type": "Person",
    "name": "PNGBlogger"
  }
}</script>
<a name='3868800323131418005'></a>
<h3 class='post-title entry-title'>
DAL &#8216;ADMIN&#8217; SUCKS K7.6 MILLION OF PRICE SUPPORT FUNDS
</h3>
<div class='post-share-buttons post-share-buttons-top'>
<div class='byline post-share-buttons goog-inline-block'>
<div aria-owns='sharing-popup-Blog1-byline-3868800323131418005' class='sharing' data-title='DAL ‘ADMIN’ SUCKS K7.6 MILLION OF PRICE SUPPORT FUNDS'>
<button aria-controls='sharing-popup-Blog1-byline-3868800323131418005' aria-label='Share' class='sharing-button touch-icon-button' id='sharing-button-Blog1-byline-3868800323131418005' role='button'>
<div class='flat-icon-button ripple'>
<svg class='svg-icon-24'>
<use xlink:href='/responsive/sprite_v1_6.css.svg#ic_share_black_24dp' xmlns:xlink='http://www.w3.org/1999/xlink'></use>
</svg>
</div>
</button>
<div class='share-buttons-container'>
<ul aria-hidden='true' aria-label='Share' class='share-buttons hidden' id='sharing-popup-Blog1-byline-3868800323131418005' role='menu'>
<li>
<span aria-label='Get link' class='sharing-platform-button sharing-element-link' data-href='https://www.blogger.com/share-post.g?blogID=6500433815145563157&postID=3868800323131418005&target=' data-url='https://www.pngblogs.com/2022/12/dal-admin-sucks-k76-million-of-price.html' role='menuitem' tabindex='-1' title='Get link'>
<svg class='svg-icon-24 touch-icon sharing-link'>
<use xlink:href='/responsive/sprite_v1_6.css.svg#ic_24_link_dark' xmlns:xlink='http://www.w3.org/1999/xlink'></use>
</svg>
<span class='platform-sharing-text'>Get link</span>
</span>
</li>
<li>
<span aria-label='Share to Facebook' class='sharing-platform-button sharing-element-facebook' data-href='https://www.blogger.com/share-post.g?blogID=6500433815145563157&postID=3868800323131418005&target=facebook' data-url='https://www.pngblogs.com/2022/12/dal-admin-sucks-k76-million-of-price.html' role='menuitem' tabindex='-1' title='Share to Facebook'>
<svg class='svg-icon-24 touch-icon sharing-facebook'>
<use xlink:href='/responsive/sprite_v1_6.css.svg#ic_24_facebook_dark' xmlns:xlink='http://www.w3.org/1999/xlink'></use>
</svg>
<span class='platform-sharing-text'>Facebook</span>
</span>
</li>
<li>
<span aria-label='Share to Twitter' class='sharing-platform-button sharing-element-twitter' data-href='https://www.blogger.com/share-post.g?blogID=6500433815145563157&postID=3868800323131418005&target=twitter' data-url='https://www.pngblogs.com/2022/12/dal-admin-sucks-k76-million-of-price.html' role='menuitem' tabindex='-1' title='Share to Twitter'>
<svg class='svg-icon-24 touch-icon sharing-twitter'>
<use xlink:href='/responsive/sprite_v1_6.css.svg#ic_24_twitter_dark' xmlns:xlink='http://www.w3.org/1999/xlink'></use>
</svg>
<span class='platform-sharing-text'>Twitter</span>
</span>
</li>
<li>
<span aria-label='Share to Pinterest' class='sharing-platform-button sharing-element-pinterest' data-href='https://www.blogger.com/share-post.g?blogID=6500433815145563157&postID=3868800323131418005&target=pinterest' data-url='https://www.pngblogs.com/2022/12/dal-admin-sucks-k76-million-of-price.html' role='menuitem' tabindex='-1' title='Share to Pinterest'>
<svg class='svg-icon-24 touch-icon sharing-pinterest'>
<use xlink:href='/responsive/sprite_v1_6.css.svg#ic_24_pinterest_dark' xmlns:xlink='http://www.w3.org/1999/xlink'></use>
</svg>
<span class='platform-sharing-text'>Pinterest</span>
</span>
</li>
<li>
<span aria-label='Email' class='sharing-platform-button sharing-element-email' data-href='https://www.blogger.com/share-post.g?blogID=6500433815145563157&postID=3868800323131418005&target=email' data-url='https://www.pngblogs.com/2022/12/dal-admin-sucks-k76-million-of-price.html' role='menuitem' tabindex='-1' title='Email'>
<svg class='svg-icon-24 touch-icon sharing-email'>
<use xlink:href='/responsive/sprite_v1_6.css.svg#ic_24_email_dark' xmlns:xlink='http://www.w3.org/1999/xlink'></use>
</svg>
<span class='platform-sharing-text'>Email</span>
</span>
</li>
<li aria-hidden='true' class='hidden'>
<span aria-label='Share to other apps' class='sharing-platform-button sharing-element-other' data-url='https://www.pngblogs.com/2022/12/dal-admin-sucks-k76-million-of-price.html' role='menuitem' tabindex='-1' title='Share to other apps'>
<svg class='svg-icon-24 touch-icon sharing-sharingOther'>
<use xlink:href='/responsive/sprite_v1_6.css.svg#ic_more_horiz_black_24dp' xmlns:xlink='http://www.w3.org/1999/xlink'></use>
</svg>
<span class='platform-sharing-text'>Other Apps</span>
</span>
</li>
</ul>
</div>
</div>
</div>
</div>
<div class='post-header'>
<div class='post-header-line-1'>
<span class='byline post-timestamp'>
<meta content='https://www.pngblogs.com/2022/12/dal-admin-sucks-k76-million-of-price.html'/>
<a class='timestamp-link' href='https://www.pngblogs.com/2022/12/dal-admin-sucks-k76-million-of-price.html' rel='bookmark' title='permanent link'>
<time class='published' datetime='2022-12-01T14:01:00+10:00' title='2022-12-01T14:01:00+10:00'>
December 01, 2022
</time>
</a>
</span>
</div>
</div>
<div class='post-body entry-content float-container' id='post-body-3868800323131418005'>
<p><i></i></p><div class="separator" style="clear: both; text-align: center;"><i><a href="https://blogger.googleusercontent.com/img/b/R29vZ2xl/AVvXsEihf6CfQxhQgwTQ-uTRF78Y547D5q5NhqEwhGIJJjiw1gd7rZHmxsX33HBnBbEgNjHbRk9KRo2puwLCgTawfqLEr3aq4WVvC1rt6e1YMNv-Lv47Yn6VH_pFJofxxc21LGHk0K57xXsMth0hHZ8XnbsML5wobpBdAT3bZ4GplmbOqc2vuBf_SK3lSCtP/s640/DAL.webp" imageanchor="1" style="margin-left: 1em; margin-right: 1em;"><img border="0" data-original-height="426" data-original-width="640" height="426" src="https://blogger.googleusercontent.com/img/b/R29vZ2xl/AVvXsEihf6CfQxhQgwTQ-uTRF78Y547D5q5NhqEwhGIJJjiw1gd7rZHmxsX33HBnBbEgNjHbRk9KRo2puwLCgTawfqLEr3aq4WVvC1rt6e1YMNv-Lv47Yn6VH_pFJofxxc21LGHk0K57xXsMth0hHZ8XnbsML5wobpBdAT3bZ4GplmbOqc2vuBf_SK3lSCtP/w640-h426/DAL.webp" width="640" /></a></i></div><i><br />by</i><a href="mailto:cyril.gare@gmail.com"> CYRIL GARE&nbsp;</a><p></p><p>Port Moresby,&nbsp; Only 250,000 public servants (plus or minus) out of 8 million Papua New Guineans eat up 30 percent of our national-common wealth or K5.2 billion of the national budget every year through their pay packets.</p><p>That&#8217;s a huge burden on the shoulder of a struggling developing nation where all socioeconomic indicators on the United Nation&#8217;s Human Development Index (HDI) scale speak low of PNG, even lower among the regional neighbors - Pacific Island Nations (PIN). This excludes the costs of public servants&#8217; traveling allowances, office rentals, utilities, vehicle hire, and such other costs that leech on public funding.</p><p>As if that&#8217;s not enough, departments and state agencies have developed a systemic tendency to ask for more and loot from the people&#8217;s share each time the pie is available. A case in point: - The Department of Agriculture and Livestock (DAL) is handling of 2022 K15 million price support/freight subsidy program funds.</p><p>Originally, K20 million was allocated but reduced to K15 million during the September supplementary budget. Batch 1 funding - K6.5 million was released. Of these monies, nothing was given to the eight (8) commodity boards to implement price support and freight subsidy at the farmer level.</p><p>Instead, K4,842,144 or 74.5 percent were burnt up at the DAL headquarter (HQ) alone on these activities: i) DAL ICT capacity building, ii) development of the corporate plan and iii) development of a national price intervention and freight subsidy policy. Balance left unused &#8211; K1,657,851.</p><p>Meaning the Marape Government had spent K50 million on price support and freight subsidy last year and again K15 million this year on a program that does not have a policy backup in place hence, illegal under PFMA requirements and law. So part of this funding was allocated to developing a &#8220;national price intervention and freight subsidy policy&#8221;.</p><p>Also, what came to light was that DAL bought three Ford Everest vehicles using this money. One is currently being used by a senior ministerial staffer of a ministry other than Agriculture. Batch 2 funding &#8211; K8.5 million. On 10th November 2022 DAL wrote to the Agriculture Minister, Hon. Aiye Tambua advising him on how it intends to expend the second batch of K8.5 million: CIC K1.5 mill, Cocoa Board K1 mill, OPIC K1.5 mill, Livestock K1.5 mill, FPDA K300,000, Rubber Board K300,000, Spice Board K300,000 and DAL itself again wants a bigger slice of the pie - K2,757,851 or 32.45 percent of K8.5 mill.</p><p>Justifications by DAL:<br /><br />&nbsp;It wanted K2,757,851 &#8220;for the price improvement interventions and freight support for the sector&#8221;, adding that &#8220;use of funds are in compliant to PFMA of which 70 percent of the fund is transferred to the commodity boards and 30 percent retained in DAL for administration and support to the sector&#8221;.Wrong:&nbsp;</p><p><span>&nbsp;&nbsp; &nbsp;</span><span>&nbsp;&nbsp; &nbsp;</span><span>&nbsp;&nbsp; &nbsp;</span><span>&nbsp;&nbsp; &nbsp;</span>i) Under PFMA only 10 per is allocated for administration,</p><p><span>&nbsp;&nbsp; &nbsp;</span><span>&nbsp;&nbsp; &nbsp;</span><span>&nbsp;&nbsp; &nbsp;</span>&nbsp;ii) price support and freight subsidy is clearly the job of commodity boards who are there with farmers down there and not the job of DAL which is policy, regulation, and technical support. It must never control price support and subsidy monies,</p><p><span>&nbsp;&nbsp; &nbsp;</span><span>&nbsp;&nbsp; &nbsp;</span><span>&nbsp;&nbsp; &nbsp;</span>&nbsp;iii) OPIC makes around K2 billion a year in export revenue, the leading agriculture earner so whygive K1.5 million?, iv) Livestock is operated under Livestock Development Corporation (LDC). It is a private company. Last year LDC received K16 million in funding without an acquittal as yet. Why K1.5 million again in this second batch of funding?</p><p>The commodity board that needs help would be CIC as it is currently fighting Coffee Berry Borer (CBB) with assistance from NAQIA funding the joint intervention and containment exercises on the ground in Jiwaka. Despite this, CBB has now spread to Simbu, Eastern Highlands, Madang, and Morobe. Cocoa Board has a clear Cocoa Industry Strategic Plan for 2016-2025 that requires a Government investment of K300 million to achieve a billion kina mark industry in five years. DAL sucks: First batch K4,842,144 plus second batch K2,757,851 equals K7,599,995 in total. Of the K15 million, DAL HQ alone sucks 50.66 percent in &#8220;administration&#8221; alone. What? Their names are used in Waigani sucks money but farmers lose big time and all the time.</p><p>A far cry</p><p>Prime Minister, James Marape thinks agriculture is &#8220;easy money&#8221;. In his 47th Independence message, he told PNG that agriculture could raise K10 billion &#8220;easy money&#8221; if one million rural families were engaged in toiling the soil and earning K10,000 each annually from agriculture &#8211; a &#8220;sleeping giant&#8230;that must be awakened now and not tomorrow&#8221;.</p><p>In 1977, the agriculture sector contributed as much as 37 percent of the GDP. Today, agriculture contributes less than 25 percent of the GDP. In the last 20 years, the agriculture sector received less than two percent of the national budget resulting in a dead-end to its core functions and effective service delivery mechanisms. The sector continues to suffer as its departmental head&#8217;s position is sailing in a debacle and continuous</p><p>Tug of war.&nbsp;</p><p>Within 12 months under Marape&#8217;s watch, DAL has changed heads four times (4 x) and staff performance and morale are at their lowest.</p><p>Conclusion</p><p>1. DAL HQ alone ate up K7,599,995 or 50.66 percent of the K15 million earmarked for 2022 price support and freight subsidy for rural farmers.</p><p>2. Furthermore to a hefty K5.2 bill wage bill for public servants every year, the &#8220;administration component&#8221; of any publicly funded project is always used as a means to loot from and cause misery to our common people. And there is no indication this evil will stop its prowess sooner or later.</p><p>3. It&#8217;s a far cry of the Prime Minister to make agriculture a K10 billion earner not now, not in five years or even 10 years if we cannot restore agriculture to its glory 1977 level.</p><p><i>The Author is a Freelance journalist based in Port Moresby, he can be contacted on.&nbsp;cyril.gare@gmail.com</i></p><p><br /></p>
</div>
<div class='post-bottom'>
<div class='post-footer float-container'>
<div class='post-footer-line post-footer-line-1'>
<span class='byline post-icons'>
<span class='item-action'>
<a href='https://www.blogger.com/email-post.g?blogID=6500433815145563157&postID=3868800323131418005' title='Email Post'>
<svg class='svg-icon-24 touch-icon sharing-icon'>
<use xlink:href='/responsive/sprite_v1_6.css.svg#ic_24_email_dark' xmlns:xlink='http://www.w3.org/1999/xlink'></use>
</svg>
</a>
</span>
</span>
</div>
<div class='post-footer-line post-footer-line-2'>
<span class='byline post-labels'>
<span class='byline-label'>
</span>
<a href='https://www.pngblogs.com/search/label/abuse' rel='tag'>abuse</a>
<a href='https://www.pngblogs.com/search/label/DAL' rel='tag'>DAL</a>
<a href='https://www.pngblogs.com/search/label/Department%20of%20Agriculture' rel='tag'>Department of Agriculture</a>
<a href='https://www.pngblogs.com/search/label/JAMES%20MARAPE' rel='tag'>JAMES MARAPE</a>
<a href='https://www.pngblogs.com/search/label/Papua%20New%20Guinea' rel='tag'>Papua New Guinea</a>
<a href='https://www.pngblogs.com/search/label/PM' rel='tag'>PM</a>
<a href='https://www.pngblogs.com/search/label/PNG' rel='tag'>PNG</a>
</span>
</div>
<div class='post-footer-line post-footer-line-3'>
</div>
</div>
<div class='post-share-buttons post-share-buttons-bottom invisible'>
<div class='byline post-share-buttons goog-inline-block'>
<div aria-owns='sharing-popup-Blog1-byline-3868800323131418005' class='sharing' data-title='DAL ‘ADMIN’ SUCKS K7.6 MILLION OF PRICE SUPPORT FUNDS'>
<button aria-controls='sharing-popup-Blog1-byline-3868800323131418005' aria-label='Share' class='sharing-button touch-icon-button' id='sharing-button-Blog1-byline-3868800323131418005' role='button'>
<div class='flat-icon-button ripple'>
<svg class='svg-icon-24'>
<use xlink:href='/responsive/sprite_v1_6.css.svg#ic_share_black_24dp' xmlns:xlink='http://www.w3.org/1999/xlink'></use>
</svg>
</div>
</button>
<div class='share-buttons-container'>
<ul aria-hidden='true' aria-label='Share' class='share-buttons hidden' id='sharing-popup-Blog1-byline-3868800323131418005' role='menu'>
<li>
<span aria-label='Get link' class='sharing-platform-button sharing-element-link' data-href='https://www.blogger.com/share-post.g?blogID=6500433815145563157&postID=3868800323131418005&target=' data-url='https://www.pngblogs.com/2022/12/dal-admin-sucks-k76-million-of-price.html' role='menuitem' tabindex='-1' title='Get link'>
<svg class='svg-icon-24 touch-icon sharing-link'>
<use xlink:href='/responsive/sprite_v1_6.css.svg#ic_24_link_dark' xmlns:xlink='http://www.w3.org/1999/xlink'></use>
</svg>
<span class='platform-sharing-text'>Get link</span>
</span>
</li>
<li>
<span aria-label='Share to Facebook' class='sharing-platform-button sharing-element-facebook' data-href='https://www.blogger.com/share-post.g?blogID=6500433815145563157&postID=3868800323131418005&target=facebook' data-url='https://www.pngblogs.com/2022/12/dal-admin-sucks-k76-million-of-price.html' role='menuitem' tabindex='-1' title='Share to Facebook'>
<svg class='svg-icon-24 touch-icon sharing-facebook'>
<use xlink:href='/responsive/sprite_v1_6.css.svg#ic_24_facebook_dark' xmlns:xlink='http://www.w3.org/1999/xlink'></use>
</svg>
<span class='platform-sharing-text'>Facebook</span>
</span>
</li>
<li>
<span aria-label='Share to Twitter' class='sharing-platform-button sharing-element-twitter' data-href='https://www.blogger.com/share-post.g?blogID=6500433815145563157&postID=3868800323131418005&target=twitter' data-url='https://www.pngblogs.com/2022/12/dal-admin-sucks-k76-million-of-price.html' role='menuitem' tabindex='-1' title='Share to Twitter'>
<svg class='svg-icon-24 touch-icon sharing-twitter'>
<use xlink:href='/responsive/sprite_v1_6.css.svg#ic_24_twitter_dark' xmlns:xlink='http://www.w3.org/1999/xlink'></use>
</svg>
<span class='platform-sharing-text'>Twitter</span>
</span>
</li>
<li>
<span aria-label='Share to Pinterest' class='sharing-platform-button sharing-element-pinterest' data-href='https://www.blogger.com/share-post.g?blogID=6500433815145563157&postID=3868800323131418005&target=pinterest' data-url='https://www.pngblogs.com/2022/12/dal-admin-sucks-k76-million-of-price.html' role='menuitem' tabindex='-1' title='Share to Pinterest'>
<svg class='svg-icon-24 touch-icon sharing-pinterest'>
<use xlink:href='/responsive/sprite_v1_6.css.svg#ic_24_pinterest_dark' xmlns:xlink='http://www.w3.org/1999/xlink'></use>
</svg>
<span class='platform-sharing-text'>Pinterest</span>
</span>
</li>
<li>
<span aria-label='Email' class='sharing-platform-button sharing-element-email' data-href='https://www.blogger.com/share-post.g?blogID=6500433815145563157&postID=3868800323131418005&target=email' data-url='https://www.pngblogs.com/2022/12/dal-admin-sucks-k76-million-of-price.html' role='menuitem' tabindex='-1' title='Email'>
<svg class='svg-icon-24 touch-icon sharing-email'>
<use xlink:href='/responsive/sprite_v1_6.css.svg#ic_24_email_dark' xmlns:xlink='http://www.w3.org/1999/xlink'></use>
</svg>
<span class='platform-sharing-text'>Email</span>
</span>
</li>
<li aria-hidden='true' class='hidden'>
<span aria-label='Share to other apps' class='sharing-platform-button sharing-element-other' data-url='https://www.pngblogs.com/2022/12/dal-admin-sucks-k76-million-of-price.html' role='menuitem' tabindex='-1' title='Share to other apps'>
<svg class='svg-icon-24 touch-icon sharing-sharingOther'>
<use xlink:href='/responsive/sprite_v1_6.css.svg#ic_more_horiz_black_24dp' xmlns:xlink='http://www.w3.org/1999/xlink'></use>
</svg>
<span class='platform-sharing-text'>Other Apps</span>
</span>
</li>
</ul>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
<section class='comments embed' data-num-comments='0' id='comments'>
<a name='comments'></a>
<h3 class='title'>Comments</h3>
<div id='Blog1_comments-block-wrapper'>
</div>
<div class='footer'>
<div class='comment-form'>
<a name='comment-form'></a>
<h4 id='comment-post-message'>Post a Comment</h4>
<p>Please free to leave comments.</p>
<a href='https://www.blogger.com/comment/frame/6500433815145563157?po=3868800323131418005&hl=en&skin=essential' id='comment-editor-src'></a>
<iframe allowtransparency='allowtransparency' class='blogger-iframe-colorize blogger-comment-from-post' frameborder='0' height='410px' id='comment-editor' name='comment-editor' src='' width='100%'></iframe>
<script src='https://www.blogger.com/static/v1/jsbin/3469866930-comment_from_post_iframe.js' type='text/javascript'></script>
<script type='text/javascript'>
      BLOG_CMT_createIframe('https://www.blogger.com/rpc_relay.html');
    </script>
</div>
</div>
</section>
</article>
</div>
</div><div class='widget PopularPosts' data-version='2' id='PopularPosts1'>
<h3 class='title'>
Popular posts from this blog
</h3>
<div class='widget-content'>
<div role='feed'>
<article class='post' role='article'>
<h3 class='post-title'><a href='https://www.pngblogs.com/2022/08/pornstars-killers-and-crooks-pangus.html'>Killer & Crook: Pangu's mission to take back PNG</a></h3>
<div class='post-header'>
<div class='post-header-line-1'>
<span class='byline post-timestamp'>
<meta content='https://www.pngblogs.com/2022/08/pornstars-killers-and-crooks-pangus.html'/>
<a class='timestamp-link' href='https://www.pngblogs.com/2022/08/pornstars-killers-and-crooks-pangus.html' rel='bookmark' title='permanent link'>
<time class='published' datetime='2022-08-07T20:40:00+10:00' title='2022-08-07T20:40:00+10:00'>
August 07, 2022
</time>
</a>
</span>
</div>
</div>
<div class='item-content float-container'>
<div class='item-thumbnail'>
<a href='https://www.pngblogs.com/2022/08/pornstars-killers-and-crooks-pangus.html'>
<img alt='Image' sizes='72px' src='https://blogger.googleusercontent.com/img/b/R29vZ2xl/AVvXsEjOCJuAvq2_mWjn4z-0Nk5dhXAdnD3-8GEux433lhpdl-czCgGmiPAKp6r8YmC1dUAawdcEvuXGq3lH3nbVAP-uM53FQs3FG-LQemcvI1esp2ZHT7gSPl4jNFXjbRsLLleh-O2xcFpbq_pG5Z6viFIRTPiYQJsnEJnLiAskoD2DyP1cgjOSPxaHiWwE/w640-h562/pangu%20candidates2.gif' srcset='https://blogger.googleusercontent.com/img/b/R29vZ2xl/AVvXsEjOCJuAvq2_mWjn4z-0Nk5dhXAdnD3-8GEux433lhpdl-czCgGmiPAKp6r8YmC1dUAawdcEvuXGq3lH3nbVAP-uM53FQs3FG-LQemcvI1esp2ZHT7gSPl4jNFXjbRsLLleh-O2xcFpbq_pG5Z6viFIRTPiYQJsnEJnLiAskoD2DyP1cgjOSPxaHiWwE/w72-h72-p-k-no-nu/pangu%20candidates2.gif 72w, https://blogger.googleusercontent.com/img/b/R29vZ2xl/AVvXsEjOCJuAvq2_mWjn4z-0Nk5dhXAdnD3-8GEux433lhpdl-czCgGmiPAKp6r8YmC1dUAawdcEvuXGq3lH3nbVAP-uM53FQs3FG-LQemcvI1esp2ZHT7gSPl4jNFXjbRsLLleh-O2xcFpbq_pG5Z6viFIRTPiYQJsnEJnLiAskoD2DyP1cgjOSPxaHiWwE/w144-h144-p-k-no-nu/pangu%20candidates2.gif 144w'/>
</a>
</div>
<div class='popular-posts-snippet snippet-container r-snippet-container'>
<div class='snippet-item r-snippetized'>
&#160; by MICHAEL PASSINGAN Pangu&#39;s long mission to Take Back PNG started with this catch cry borrowed from Oro Governor Garry Juffa. James Marape had to find something to resonate with the people of PNG, he until recently was in the inner sanctum of the PNC-led government covering up and doing the dirty deeds for Peter O&#39;Neill. Seeing that the country was not going anywhere to his liking and having the financial backing of three provincial governments (Enga, Southern Highlands, and Hela) he wrestled the powers off Peter O&#39;Neill.&#160; Remember it was not smooth and easy at first for him, he had to prove his worth, in the secret ballot that took place that night, Patrick Pruaitch and William Duma were the eventual winners, he never came close, they say in politics there is no permanent friend or permanent enemy, what does the Igiri man do? He crawls back to Crown Plaza begging the support for PNC, the kingmaker here is Michael Buku Nali who has since lost his Mendi Open Seat, Nali is
</div>
<a class='snippet-fade r-snippet-fade hidden' href='https://www.pngblogs.com/2022/08/pornstars-killers-and-crooks-pangus.html'></a>
</div>
<div class='jump-link flat-button ripple'>
<a href='https://www.pngblogs.com/2022/08/pornstars-killers-and-crooks-pangus.html' title='Killer & Crook: Pangu&#39;s mission to take back PNG'>
Read more
</a>
</div>
</div>
</article>
<article class='post' role='article'>
<h3 class='post-title'><a href='https://www.pngblogs.com/2022/07/pm-marape-is-involved-in-smuggling-cash.html'>PM MARAPE IS INVOLVED IN SMUGGLING CASH & UNIFORMS - GOVT OFFICIAL</a></h3>
<div class='post-header'>
<div class='post-header-line-1'>
<span class='byline post-timestamp'>
<meta content='https://www.pngblogs.com/2022/07/pm-marape-is-involved-in-smuggling-cash.html'/>
<a class='timestamp-link' href='https://www.pngblogs.com/2022/07/pm-marape-is-involved-in-smuggling-cash.html' rel='bookmark' title='permanent link'>
<time class='published' datetime='2022-07-07T10:24:00+10:00' title='2022-07-07T10:24:00+10:00'>
July 07, 2022
</time>
</a>
</span>
</div>
</div>
<div class='item-content float-container'>
<div class='item-thumbnail'>
<a href='https://www.pngblogs.com/2022/07/pm-marape-is-involved-in-smuggling-cash.html'>
<img alt='Image' sizes='72px' src='https://blogger.googleusercontent.com/img/b/R29vZ2xl/AVvXsEjLlKyCzYPuhdrjybtBZjPVWm5dqNpRqmoNgU4573VCnnnEWiUWNtVjiylvPHZgGacbU9ctN5nXpQPun5rqVLqAmsHgtcqnM-2KcGEp7eMLYxHUuMwE_i3RK6OcQCQAaJkNAIb5TZjxRh-ZM5yOI40Yl3CoH-TI2ZoqU6d_jDgBepDTTPzkx01z2Xun/w640-h422/291492088_748505909722779_5145890723759664241_n.jpg' srcset='https://blogger.googleusercontent.com/img/b/R29vZ2xl/AVvXsEjLlKyCzYPuhdrjybtBZjPVWm5dqNpRqmoNgU4573VCnnnEWiUWNtVjiylvPHZgGacbU9ctN5nXpQPun5rqVLqAmsHgtcqnM-2KcGEp7eMLYxHUuMwE_i3RK6OcQCQAaJkNAIb5TZjxRh-ZM5yOI40Yl3CoH-TI2ZoqU6d_jDgBepDTTPzkx01z2Xun/w72-h72-p-k-no-nu/291492088_748505909722779_5145890723759664241_n.jpg 72w, https://blogger.googleusercontent.com/img/b/R29vZ2xl/AVvXsEjLlKyCzYPuhdrjybtBZjPVWm5dqNpRqmoNgU4573VCnnnEWiUWNtVjiylvPHZgGacbU9ctN5nXpQPun5rqVLqAmsHgtcqnM-2KcGEp7eMLYxHUuMwE_i3RK6OcQCQAaJkNAIb5TZjxRh-ZM5yOI40Yl3CoH-TI2ZoqU6d_jDgBepDTTPzkx01z2Xun/w144-h144-p-k-no-nu/291492088_748505909722779_5145890723759664241_n.jpg 144w'/>
</a>
</div>
<div class='popular-posts-snippet snippet-container r-snippet-container'>
<div class='snippet-item r-snippetized'>
&#160; by A GOVERNMENT OFFICIAL IN TARI The issue on PM denying on the 1.5m kina is a lie. James Marape is the biggest conman and liar in Papua New Guinea, He or Pangu chartered a Fokker 100 flight and and airlifted supporters to Tari. The first was the incident where uniforms were found in procession of travelling passengers. It was in the news. The 1.5m kina incident is the second charter in which his son was on board the plane. He was caught inside the airport tarmac and not outside as he stated. He is lying through his teeth. The other issue is why did Exxon Mobil allowing this charters to land in Komo airport as it is a private airport. They only allow for emergency or the aircraft is providing some service orientated deliveries for national government or NGO. ExxonMobil is been biased to Pangu to form the government so they allowed their airport ferry Pangu supporters to Tari and vote for Marape.
</div>
<a class='snippet-fade r-snippet-fade hidden' href='https://www.pngblogs.com/2022/07/pm-marape-is-involved-in-smuggling-cash.html'></a>
</div>
<div class='jump-link flat-button ripple'>
<a href='https://www.pngblogs.com/2022/07/pm-marape-is-involved-in-smuggling-cash.html' title='PM MARAPE IS INVOLVED IN SMUGGLING CASH & UNIFORMS - GOVT OFFICIAL'>
Read more
</a>
</div>
</div>
</article>
<article class='post' role='article'>
<h3 class='post-title'><a href='https://www.pngblogs.com/2022/09/pangu-fraudster-baby-rex-kiponge-aka.html'>PANGU FRAUDSTER BABY: REX KIPONGE aka TIMOTHY KAIPAL</a></h3>
<div class='post-header'>
<div class='post-header-line-1'>
<span class='byline post-timestamp'>
<meta content='https://www.pngblogs.com/2022/09/pangu-fraudster-baby-rex-kiponge-aka.html'/>
<a class='timestamp-link' href='https://www.pngblogs.com/2022/09/pangu-fraudster-baby-rex-kiponge-aka.html' rel='bookmark' title='permanent link'>
<time class='published' datetime='2022-09-27T13:33:00+10:00' title='2022-09-27T13:33:00+10:00'>
September 27, 2022
</time>
</a>
</span>
</div>
</div>
<div class='item-content float-container'>
<div class='item-thumbnail'>
<a href='https://www.pngblogs.com/2022/09/pangu-fraudster-baby-rex-kiponge-aka.html'>
<img alt='Image' sizes='72px' src='https://blogger.googleusercontent.com/img/b/R29vZ2xl/AVvXsEgpPqQREblLdY5lVMfl6vxmECqDQ0WLSvsYaDj74LY8IN_4piF_hkF2tK8NBOXzIYzsSgG1xFCXmhQVkr8I9vkEvx_OuzvbCq8fORi2-xe76msXTunuMkTEGr9eRG6yiuajVvNhZnEQK7ffvRSi_lCxFgGmaltEeAxBAFLbYp_apG14ascIVt5q34y3/w640-h336/image0%20(3).jpeg' srcset='https://blogger.googleusercontent.com/img/b/R29vZ2xl/AVvXsEgpPqQREblLdY5lVMfl6vxmECqDQ0WLSvsYaDj74LY8IN_4piF_hkF2tK8NBOXzIYzsSgG1xFCXmhQVkr8I9vkEvx_OuzvbCq8fORi2-xe76msXTunuMkTEGr9eRG6yiuajVvNhZnEQK7ffvRSi_lCxFgGmaltEeAxBAFLbYp_apG14ascIVt5q34y3/w72-h72-p-k-no-nu/image0%20(3).jpeg 72w, https://blogger.googleusercontent.com/img/b/R29vZ2xl/AVvXsEgpPqQREblLdY5lVMfl6vxmECqDQ0WLSvsYaDj74LY8IN_4piF_hkF2tK8NBOXzIYzsSgG1xFCXmhQVkr8I9vkEvx_OuzvbCq8fORi2-xe76msXTunuMkTEGr9eRG6yiuajVvNhZnEQK7ffvRSi_lCxFgGmaltEeAxBAFLbYp_apG14ascIVt5q34y3/w144-h144-p-k-no-nu/image0%20(3).jpeg 144w'/>
</a>
</div>
<div class='popular-posts-snippet snippet-container r-snippet-container'>
<div class='snippet-item r-snippetized'>
MARAPE ROSSO GOVERNMENT IGNORING THE MANAGEMENT AND BOARD ISSUE AT NATIONAL AIRPORTS CORPORATION (NAC) IS NOW COMPROMISING THE AVIATION SAFETY IN THE COUNTRY. by TONDE KAIMI  The  Government of the day, what many Papua New Guineans will say, has deliberately failed and ignored addressing the NAC management and Board saga that has now compromised aviation safety in the country. The closure of Nadzab, Kiunga and now Buka airports is just the tip of the iceberg, more airports to face a similar fate, and yet PM Marape is still allowing illegal non-qualified people in the management and the board of one of the biggest state entities in the country. The Government has failed to address the following significant NAC matters that have now reached critical stages of mass airport closures; &#8226; Mismanagement and abuse of office by former CA Minister Seki Agisa and Rex Kiponge. Misappropriation of K500,000 NAC money paid to the wife of Warner Shand Lawyers Dan Kakarya coincidently is currently the L
</div>
<a class='snippet-fade r-snippet-fade hidden' href='https://www.pngblogs.com/2022/09/pangu-fraudster-baby-rex-kiponge-aka.html'></a>
</div>
<div class='jump-link flat-button ripple'>
<a href='https://www.pngblogs.com/2022/09/pangu-fraudster-baby-rex-kiponge-aka.html' title='PANGU FRAUDSTER BABY: REX KIPONGE aka TIMOTHY KAIPAL'>
Read more
</a>
</div>
</div>
</article>
<article class='post' role='article'>
<h3 class='post-title'><a href='https://www.pngblogs.com/2022/11/an-open-letter-to-justin-buttman.html'>AN OPEN LETTER TO JUSTIN "BUTTMAN" TKATCHENKO</a></h3>
<div class='post-header'>
<div class='post-header-line-1'>
<span class='byline post-timestamp'>
<meta content='https://www.pngblogs.com/2022/11/an-open-letter-to-justin-buttman.html'/>
<a class='timestamp-link' href='https://www.pngblogs.com/2022/11/an-open-letter-to-justin-buttman.html' rel='bookmark' title='permanent link'>
<time class='published' datetime='2022-11-24T06:39:00+10:00' title='2022-11-24T06:39:00+10:00'>
November 24, 2022
</time>
</a>
</span>
</div>
</div>
<div class='item-content float-container'>
<div class='item-thumbnail'>
<a href='https://www.pngblogs.com/2022/11/an-open-letter-to-justin-buttman.html'>
<img alt='Image' sizes='72px' src='https://blogger.googleusercontent.com/img/b/R29vZ2xl/AVvXsEi2YHWEF2j_fWpmQQqU52X2sv1epPag4op_sAjtfbVKl2_n9CNQpbPN6wqffYVQwN7vzzNhkQXXI-qjG4BoGw5H7Sfa-9i1wK4enmIJVvzeNTF6BB0LksBT1I2z-Y-3S6kdJPR8VA7YtpqJ9HSbNZ6b99x4HqfcuyWONl_CKKtjgm74_ZyJLSa8yk_S/w640-h640/photo.jpg' srcset='https://blogger.googleusercontent.com/img/b/R29vZ2xl/AVvXsEi2YHWEF2j_fWpmQQqU52X2sv1epPag4op_sAjtfbVKl2_n9CNQpbPN6wqffYVQwN7vzzNhkQXXI-qjG4BoGw5H7Sfa-9i1wK4enmIJVvzeNTF6BB0LksBT1I2z-Y-3S6kdJPR8VA7YtpqJ9HSbNZ6b99x4HqfcuyWONl_CKKtjgm74_ZyJLSa8yk_S/w72-h72-p-k-no-nu/photo.jpg 72w, https://blogger.googleusercontent.com/img/b/R29vZ2xl/AVvXsEi2YHWEF2j_fWpmQQqU52X2sv1epPag4op_sAjtfbVKl2_n9CNQpbPN6wqffYVQwN7vzzNhkQXXI-qjG4BoGw5H7Sfa-9i1wK4enmIJVvzeNTF6BB0LksBT1I2z-Y-3S6kdJPR8VA7YtpqJ9HSbNZ6b99x4HqfcuyWONl_CKKtjgm74_ZyJLSa8yk_S/w144-h144-p-k-no-nu/photo.jpg 144w'/>
</a>
</div>
<div class='popular-posts-snippet snippet-container r-snippet-container'>
<div class='snippet-item r-snippetized'>
We challenge you to explain to the 10 million people of PNG the following Foreign Policy Activities you have conducted so far as per your &quot;Ministerial Determination&quot; without an Act giving your corporate sole powers to sign bilateral treaties, including military that impinges on national security and constitutional sovereignty of PNG. 1. The Australian-sponsored Fragility Act that the USA is championing. Did you and your Department, together with all security governance institutions and research bodies do a thorough implication of this Act which would have informed Cabinet and Parliament for its educated and informed decision? Did the Parliamentary Committee on Defense and Foreign Affairs fully appraise of its adverse implications on the independent state of PNG, let alone State Solicitors&#39; legal clearance? 2. Did the recently signed Shiprider Agreement with the USA undergo similar scrutiny and vetting by responsible bodies such as in 1 above? Ship rider Agreement would al
</div>
<a class='snippet-fade r-snippet-fade hidden' href='https://www.pngblogs.com/2022/11/an-open-letter-to-justin-buttman.html'></a>
</div>
<div class='jump-link flat-button ripple'>
<a href='https://www.pngblogs.com/2022/11/an-open-letter-to-justin-buttman.html' title='AN OPEN LETTER TO JUSTIN "BUTTMAN" TKATCHENKO'>
Read more
</a>
</div>
</div>
</article>
<article class='post' role='article'>
<h3 class='post-title'><a href='https://www.pngblogs.com/2022/11/death-of-police-officer-in-hela-is-wake.html'>DEATH OF A POLICE OFFICER IN HELA IS A WAKE UP CALL</a></h3>
<div class='post-header'>
<div class='post-header-line-1'>
<span class='byline post-timestamp'>
<meta content='https://www.pngblogs.com/2022/11/death-of-police-officer-in-hela-is-wake.html'/>
<a class='timestamp-link' href='https://www.pngblogs.com/2022/11/death-of-police-officer-in-hela-is-wake.html' rel='bookmark' title='permanent link'>
<time class='published' datetime='2022-11-03T06:31:00+10:00' title='2022-11-03T06:31:00+10:00'>
November 03, 2022
</time>
</a>
</span>
</div>
</div>
<div class='item-content float-container'>
<div class='item-thumbnail'>
<a href='https://www.pngblogs.com/2022/11/death-of-police-officer-in-hela-is-wake.html'>
<img alt='Image' sizes='72px' src='https://blogger.googleusercontent.com/img/a/AVvXsEicaGSsbgSXbLKuLIhy1j8ThBBRKGh616z9p8mgbPfxAwlB4QbAGWmuD-OizKh9HQcB7rf5Qe7-2Jr-AVIzX0-rK3bTbehd5BgIw06GHyFOepfeMGQln8RNW5SCeBbg9fbwdQCzFozAC8UhgKwCCApq7uBBBSVnQiAq39G-g7_5pHXdrb2pIn3cIaLZ=w640-h312' srcset='https://blogger.googleusercontent.com/img/a/AVvXsEicaGSsbgSXbLKuLIhy1j8ThBBRKGh616z9p8mgbPfxAwlB4QbAGWmuD-OizKh9HQcB7rf5Qe7-2Jr-AVIzX0-rK3bTbehd5BgIw06GHyFOepfeMGQln8RNW5SCeBbg9fbwdQCzFozAC8UhgKwCCApq7uBBBSVnQiAq39G-g7_5pHXdrb2pIn3cIaLZ=w72-h72-p-k-no-nu 72w, https://blogger.googleusercontent.com/img/a/AVvXsEicaGSsbgSXbLKuLIhy1j8ThBBRKGh616z9p8mgbPfxAwlB4QbAGWmuD-OizKh9HQcB7rf5Qe7-2Jr-AVIzX0-rK3bTbehd5BgIw06GHyFOepfeMGQln8RNW5SCeBbg9fbwdQCzFozAC8UhgKwCCApq7uBBBSVnQiAq39G-g7_5pHXdrb2pIn3cIaLZ=w144-h144-p-k-no-nu 144w'/>
</a>
</div>
<div class='popular-posts-snippet snippet-container r-snippet-container'>
<div class='snippet-item r-snippetized'>
by &#160;Paul Amatio There have been a lot of talks recently on social media asking the Prime Minister a very simple question: &#8220;IF YOU CAN NOT TAKE BACK TARI, HOW WILL YOU TAKE BACK PNG?&#8221; This is a very valid question. While he may have been PM of PNG for only a few years, he has been a member of the Tari/Pori Open for over a decade. In his term of parliament, we have witnessed the development of the Hides Gas project from its infancy to its current stage where it is making billions for ExxonMobil and ZERO for Hela and Tari. If we kept proper statistics in this country, we will see that since his ascension to the PM&#39;s chair, we have seen a huge increase in migration from Tari out to other urban centers throughout PNG. And with this migration, come the problems they bring with them out of Tari to the towns and cities of once relatively peaceful places. One could be forgiven for mistaking Port Moresby for Tari town! It there were any statistical correlations to be drawn, one may safely (i
</div>
<a class='snippet-fade r-snippet-fade hidden' href='https://www.pngblogs.com/2022/11/death-of-police-officer-in-hela-is-wake.html'></a>
</div>
<div class='jump-link flat-button ripple'>
<a href='https://www.pngblogs.com/2022/11/death-of-police-officer-in-hela-is-wake.html' title='DEATH OF A POLICE OFFICER IN HELA IS A WAKE UP CALL'>
Read more
</a>
</div>
</div>
</article>
<article class='post' role='article'>
<h3 class='post-title'><a href='https://www.pngblogs.com/2022/11/moni-bilong-bilasim-ol-yethusait-wari.html'>MONI BILONG BILASIM OL YET...HUSAIT WARI LONG U?</a></h3>
<div class='post-header'>
<div class='post-header-line-1'>
<span class='byline post-timestamp'>
<meta content='https://www.pngblogs.com/2022/11/moni-bilong-bilasim-ol-yethusait-wari.html'/>
<a class='timestamp-link' href='https://www.pngblogs.com/2022/11/moni-bilong-bilasim-ol-yethusait-wari.html' rel='bookmark' title='permanent link'>
<time class='published' datetime='2022-11-02T11:48:00+10:00' title='2022-11-02T11:48:00+10:00'>
November 02, 2022
</time>
</a>
</span>
</div>
</div>
<div class='item-content float-container'>
<div class='item-thumbnail'>
<a href='https://www.pngblogs.com/2022/11/moni-bilong-bilasim-ol-yethusait-wari.html'>
<img alt='Image' sizes='72px' src='https://blogger.googleusercontent.com/img/b/R29vZ2xl/AVvXsEjTjFnNCedi7EPyyAe7vX7iUcMbAcQ4iV_VIG1DbM459ckLBa5I680zR9aTwJTIRjfipzQOcvoz56P_8Qr6gi0999vABY8ztJJwGbfEQLQn7CPTySC7dTCFQDHIGXbCBSXb_WojMV3P8CYCcstw9sI_c1DLy8Lb55x3la3okl1vp4Mqnbq-KUeavOnP/w640-h282/Marape%20Stuckey%20PNGBlogs2.jpg' srcset='https://blogger.googleusercontent.com/img/b/R29vZ2xl/AVvXsEjTjFnNCedi7EPyyAe7vX7iUcMbAcQ4iV_VIG1DbM459ckLBa5I680zR9aTwJTIRjfipzQOcvoz56P_8Qr6gi0999vABY8ztJJwGbfEQLQn7CPTySC7dTCFQDHIGXbCBSXb_WojMV3P8CYCcstw9sI_c1DLy8Lb55x3la3okl1vp4Mqnbq-KUeavOnP/w72-h72-p-k-no-nu/Marape%20Stuckey%20PNGBlogs2.jpg 72w, https://blogger.googleusercontent.com/img/b/R29vZ2xl/AVvXsEjTjFnNCedi7EPyyAe7vX7iUcMbAcQ4iV_VIG1DbM459ckLBa5I680zR9aTwJTIRjfipzQOcvoz56P_8Qr6gi0999vABY8ztJJwGbfEQLQn7CPTySC7dTCFQDHIGXbCBSXb_WojMV3P8CYCcstw9sI_c1DLy8Lb55x3la3okl1vp4Mqnbq-KUeavOnP/w144-h144-p-k-no-nu/Marape%20Stuckey%20PNGBlogs2.jpg 144w'/>
</a>
</div>
<div class='popular-posts-snippet snippet-container r-snippet-container'>
<div class='snippet-item r-snippetized'>
What happened to the K611 Million Household Assistance Package? To throw off the scent of its failures the government hastily creates another smoke screen hoping to wriggle out clean in what the pompous Treasurer eloquently puts it, &quot;Marape&#39;s 13-Year Budget Repair Plan makes PNG&#39;s debt risks sustainable.&quot; Not so fast Mr. Treasurer! Let&#39;s start with what happened to the K611 Million Household Assistance Package to help families put food on the table across the country on the adverse effects of high inflation.&#160; On the budget papers and grand speeches in parliament, it sounds good but on the food table, it is not their day in and day out. There has been no noticeable reduction in the prices of key household commodities despite the Government&#8217;s allocation of K100 million for this purpose in the recent Supplementary Budget. In the Supplementary Budget presentation on the 2nd of September 2022, the Treasurer informed Parliament that the Government had announced way back
</div>
<a class='snippet-fade r-snippet-fade hidden' href='https://www.pngblogs.com/2022/11/moni-bilong-bilasim-ol-yethusait-wari.html'></a>
</div>
<div class='jump-link flat-button ripple'>
<a href='https://www.pngblogs.com/2022/11/moni-bilong-bilasim-ol-yethusait-wari.html' title='MONI BILONG BILASIM OL YET...HUSAIT WARI LONG U?'>
Read more
</a>
</div>
</div>
</article>
<article class='post' role='article'>
<h3 class='post-title'><a href='https://www.pngblogs.com/2022/11/after-gun-surrender-and-peace-ceremony.html'>After gun surrender and peace ceremony, Hela warlords still live.</a></h3>
<div class='post-header'>
<div class='post-header-line-1'>
<span class='byline post-timestamp'>
<meta content='https://www.pngblogs.com/2022/11/after-gun-surrender-and-peace-ceremony.html'/>
<a class='timestamp-link' href='https://www.pngblogs.com/2022/11/after-gun-surrender-and-peace-ceremony.html' rel='bookmark' title='permanent link'>
<time class='published' datetime='2022-11-07T10:23:00+10:00' title='2022-11-07T10:23:00+10:00'>
November 07, 2022
</time>
</a>
</span>
</div>
</div>
<div class='item-content float-container'>
<div class='item-thumbnail'>
<a href='https://www.pngblogs.com/2022/11/after-gun-surrender-and-peace-ceremony.html'>
<img alt='Image' sizes='72px' src='https://blogger.googleusercontent.com/img/b/R29vZ2xl/AVvXsEjnl2L9-_6Fa5kCRnopBg5LlDcG62_Mny8jNKjH725z_ZXQ-h1Yz7MLLMfHAMJveYlqXGgH8u-ZcGJMmpK2x2xtMBZjzZ7UWDNaEGTe74yzZHI_ld0vhqRukHv-sXnn19gvDswwj9YKNSliJOfQL3Hk0JO5l_rZNsiTXq7tk2ZbB0jr28gXWjAaeyUg/w640-h602/199284424_341257147491783_4711962397299386834_n.jpg' srcset='https://blogger.googleusercontent.com/img/b/R29vZ2xl/AVvXsEjnl2L9-_6Fa5kCRnopBg5LlDcG62_Mny8jNKjH725z_ZXQ-h1Yz7MLLMfHAMJveYlqXGgH8u-ZcGJMmpK2x2xtMBZjzZ7UWDNaEGTe74yzZHI_ld0vhqRukHv-sXnn19gvDswwj9YKNSliJOfQL3Hk0JO5l_rZNsiTXq7tk2ZbB0jr28gXWjAaeyUg/w72-h72-p-k-no-nu/199284424_341257147491783_4711962397299386834_n.jpg 72w, https://blogger.googleusercontent.com/img/b/R29vZ2xl/AVvXsEjnl2L9-_6Fa5kCRnopBg5LlDcG62_Mny8jNKjH725z_ZXQ-h1Yz7MLLMfHAMJveYlqXGgH8u-ZcGJMmpK2x2xtMBZjzZ7UWDNaEGTe74yzZHI_ld0vhqRukHv-sXnn19gvDswwj9YKNSliJOfQL3Hk0JO5l_rZNsiTXq7tk2ZbB0jr28gXWjAaeyUg/w144-h144-p-k-no-nu/199284424_341257147491783_4711962397299386834_n.jpg 144w'/>
</a>
</div>
<div class='popular-posts-snippet snippet-container r-snippet-container'>
<div class='snippet-item r-snippetized'>
by DAVID LEPI Since Tari/Pori MP James Marape took over the nation&#39;s leadership, Papua New Guinea has experienced unprecedented and widespread violence, damage to life and property and death. On the broader scale violence and lawlessness is sporadically sweeping across the country and on the lesser the perpetrators happen to come from a particular ethnicity.&#160; In 2019 ABC News reported at least 16 people, mostly women and children, were killed in the village of Karida in Hela Province from an outbreak of an old tribal conflict. Police announced a final death toll of 18 people, which included the unborn babies of two of the women who were believed to have been pregnant. In that same year in October a police patrol was ambushed on the Tokoyo bridge near Tokia/Kuparo village in Hela and policeman Sergeant David Hale was shot and died instantly and Constable James Kobol sustained seriouse injuries who later recovered but is believed to suffer severe post traumatic disorder. Lape Mole fr
</div>
<a class='snippet-fade r-snippet-fade hidden' href='https://www.pngblogs.com/2022/11/after-gun-surrender-and-peace-ceremony.html'></a>
</div>
<div class='jump-link flat-button ripple'>
<a href='https://www.pngblogs.com/2022/11/after-gun-surrender-and-peace-ceremony.html' title='After gun surrender and peace ceremony, Hela warlords still live.'>
Read more
</a>
</div>
</div>
</article>
</div>
</div>
</div></div>
</main>
</div>
<footer class='footer section' id='footer' name='Footer'><div class='widget Attribution' data-version='2' id='Attribution1'>
<div class='widget-content'>
<div class='blogger'>
<a href='https://www.blogger.com' rel='nofollow'>
<svg class='svg-icon-24'>
<use xlink:href='/responsive/sprite_v1_6.css.svg#ic_post_blogger_black_24dp' xmlns:xlink='http://www.w3.org/1999/xlink'></use>
</svg>
Powered by Blogger
</a>
</div>
</div>
</div>
</footer>
</div>
</div>
</div>
<aside class='sidebar-container container sidebar-invisible' role='complementary'>
<div class='navigation'>
<button class='svg-icon-24-button flat-icon-button ripple sidebar-back'>
<svg class='svg-icon-24'>
<use xlink:href='/responsive/sprite_v1_6.css.svg#ic_arrow_back_black_24dp' xmlns:xlink='http://www.w3.org/1999/xlink'></use>
</svg>
</button>
</div>
<div class='sidebar_top_wrapper no-items'>
<div class='sidebar_top no-items section' id='sidebar_top' name='Sidebar (Top)'>
</div>
</div>
<div class='sidebar_bottom section' id='sidebar_bottom' name='Sidebar (Bottom)'><div class='widget HTML' data-version='2' id='HTML1'>
<script type='text/javascript'>
var disqus_shortname = 'papuanewguineablogs';
var disqus_blogger_current_url = "https://www.pngblogs.com/2022/12/dal-admin-sucks-k76-million-of-price.html";
if (!disqus_blogger_current_url.length) {
disqus_blogger_current_url = "https://www.pngblogs.com/2022/12/dal-admin-sucks-k76-million-of-price.html";
}
var disqus_blogger_homepage_url = "https://www.pngblogs.com/";
var disqus_blogger_canonical_homepage_url = "https://www.pngblogs.com/";
</script>
<style type='text/css'>
#comments {display:none;}
</style>
<script type='text/javascript'>
(function() {
    var bloggerjs = document.createElement('script');
    bloggerjs.type = 'text/javascript';
    bloggerjs.async = true;
    bloggerjs.src = '//' + disqus_shortname + '.disqus.com/blogger_item.js';
    (document.getElementsByTagName('head')[0] || document.getElementsByTagName('body')[0]).appendChild(bloggerjs);
})();
</script>
<style type='text/css'>
.post-comment-link { visibility: hidden; }
</style>
<script type='text/javascript'>
(function() {
var bloggerjs = document.createElement('script');
bloggerjs.type = 'text/javascript';
bloggerjs.async = true;
bloggerjs.src = '//' + disqus_shortname + '.disqus.com/blogger_index.js';
(document.getElementsByTagName('head')[0] || document.getElementsByTagName('body')[0]).appendChild(bloggerjs);
})();
</script>
</div></div>
</aside>
<script type="text/javascript" src="https://resources.blogblog.com/blogblog/data/res/3026064950-strm_compiled.js" async="true"></script>

<script type="text/javascript" src="//www.google.com/js/bg/rVlqs_C6MEoymNIgrpYBY2eJfhVJuMjEUeWab4z9yRM.js"></script><script type="text/javascript" src="/b/csi.js?h=rVlqs_C6MEoymNIgrpYBY2eJfhVJuMjEUeWab4z9yRM" defer="true"></script>

<script type="text/javascript" src="https://www.blogger.com/static/v1/widgets/2342155703-widgets.js"></script>
<script type='text/javascript'>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</script>
</body>
</html>